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Warranty
The GPIB hardware is warranted against defects in materials and workmanship for a period of two years from the
shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or repl
equipment that proves to be defective during the warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evid
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that 
execute programming instructions if National Instruments receives notice of such defects during the warranty pe
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outs
of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping
of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefull
reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments re
the right to make changes to subsequent editions of this document without prior notice to holders of this edition. 
reader should consult National Instruments if errors are suspected. In no event shall National Instruments be liab
any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND 
SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S 
RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE 
LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL  INSTRUMENTS WILL  NOT BE LIABLE  FOR 
DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, 
EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of National Instruments will apply 
regardless of the form of action, whether in contract or tort, including negligence. Any action against National 
Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be li
any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not c
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments 
installation, operation, or maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, 
negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside rea 
control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mecha
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, wit
the prior written consent of National Instruments Corporation.

Trademarks
CVI™, HS488™, natinst.com™, and NI-488.2™ are trademarks of National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS
National Instruments products are not designed with components and testing intended to ensure a level of reliab
suitable for use in treatment and diagnosis of humans. Applications of National Instruments products involving m
or clinical treatment can create a potential for accidental injury caused by product failure, or by errors on the part
user or application designer. Any use or application of National Instruments products for or involving medical or cl
treatment must be performed by properly trained and qualified medical personnel, and all traditional medical safeg
equipment, and procedures that are appropriate in the particular situation to prevent serious injury or death should
continue to be used when National Instruments products are being used. National Instruments products are NOT i
to be a substitute for any form of established process, procedure, or equipment used to monitor or safeguard huma
and safety in medical or clinical treatment.
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The following conventions are used in this manual:

<> Angle brackets that contain numbers separated by an ellipsis represe
range of values associated with a bit or signal name—for example, 
DBIO<3..0>.

» The » symbol leads you through nested menu items and dialog box opt
to a final action. The sequence File»Page Setup»Options directs you to 
open the File menu, select the Page Setup item, and select Options from 
the last dialog box.

bold Bold text denotes items that you must select or click on in the software
such as menu items and dialog box options. Bold text also denotes 
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introdu
to a key concept. This font also denotes text that is a placeholder for a w
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from 
keyboard, sections of code, programming examples, and syntax exam
This font is also used for the proper names of disk drives, paths, directo
programs, subprograms, subroutines, device names, functions, operat
variables, filenames and extensions, and code excerpts.
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GPIB Analyzer Overview

This chapter gives an overview of the GPIB analyzer software.

About This Manual
This manual contains instructions to help you use the GPIB analyzer 
software. The GPIB analyzer software is meant to be used with Micros
Windows and with one of the National Instruments GPIB interfaces th
supports the GPIB analyzer. This manual assumes that you are alread
familiar with the Windows system you are using.

GPIB Analyzer Overview
You can use the GPIB analyzer application for testing, debugging, and
analysis. It can monitor, capture, and participate in bus activity on the 
GPIB. You can use the GPIB analyzer to test and debug your own 
applications by monitoring and capturing GPIB activity while your 
application is running. The analyzer also has tools to help you analyze
data that you capture. Analyzing this data can help you solve many of
difficulties associated with GPIB communication, such as addressing 
inconsistencies, protocol violations, and simple bus timeout conditions

The GPIB analyzer software works under Windows 98/95 only when a
AT-GPIB/TNT+ or PCMCIA-GPIB+ is installed. It works under 
Windows NT only when an AT-GPIB/TNT+ or PCI-GPIB+ is installed.

Online Help
The GPIB analyzer application includes an online help system, which y
can access while running the analyzer by pressing <F1> or using the Help 
menu. The online help contains basically the same information as this 
manual.
lyzer User Manual
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Features of the GPIB Analyzer
The GPIB analyzer, created with the National Instruments 
LabWindows/CVI development environment, has several major featur

• Settings configuration—Allows configuration of capture and trigge
settings.

• Action window—Starts and stops capturing and/or triggering.

• Bus Monitor  window—Displays and allows you to modify the state o
each of the GPIB data and control lines.

• Capture Display window—Displays captured GPIB events.

• Search capability—Allows searches within a capture display.

Capturing Data with the GPIB Analyzer
The analyzer can capture and display data, including any combination
the following GPIB events: data transfers, command transfers, control 
transitions, handshake line transitions, and parallel poll responses. You
participate in handshaking or do a non-intrusive capture.

You might want to capture and display data based on a specific bus ev
without knowing when the event might occur. In this case, you can spe
a trigger condition and capture any number of events before and after
trigger condition occurs. The capture operation proceeds according to
settings configuration.

The analyzer can perform the acceptor handshake while capturing, an
can time stamp captured events. The number of recorded capture even
be configured and is limited only by the memory available on your 
computer.

Analyzing Captured Data with the GPIB Analyzer
The GPIB analyzer provides several features to help you analyze data
you have captured:

• Use markers for highlighting and examining specific transactions i
the captured data and for determining elapsed time between capt
events.

• Use the flexible pattern-search utility to locate specific bus pattern

• Store captured data to disk for later review in the capture display.

• Print captured data to a selected printer.
GPIB Analyzer User Manual 1-2 © National Instruments Corporation
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You can reload previously saved capture events for later review and 
analysis. You can even have multiple capture displays open so that you
analyze current bus activity in one display and the previously captured 
in another display.

Starting the GPIB Analyzer
Launch the GPIB analyzer application from the Measurement & 
Automation Explorer, which is started by selecting Start»Programs» 
National Instruments NI-488.2»Explore GPIB. To start the GPIB 
analyzer, select a GPIB interface under Devices and Interfaces in the left 
window frame, right-click, and select GPIB Analyzer.
© National Instruments Corporation 1-3 GPIB Analyzer User Manual
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GPIB Analyzer Features

This chapter describes the features of the GPIB analyzer application.

The features are as follows:

• Settings configuration—Allows configuration of capture and trigge
settings.

• Action window—Starts and stops capturing and/or triggering.

• Bus Monitor  window—Displays and allows you to modify the state
of each of the GPIB data and control lines.

• Capture Display window—Displays captured GPIB events.

• Search capability—Allows searches within a capture display.

Figure 2-1 shows the main GPIB analyzer window. The Action and 
Bus Monitor  windows are always open.
lyzer User Manual
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Figure 2-1.  Main Window of the GPIB Analyzer

Main GPIB Analyzer Window
The GPIB analyzer opens with the main window, which includes the 
Action and Bus Monitor windows. The following sections describe the 
menu choices from the main window of the GPIB analyzer.

File»New Capture Display
Choosing New Capture Display from the File menu opens a new, active
capture display. When you start capturing GPIB events by selecting on
the capture buttons in the Action window, you can view them in the active
capture display.
GPIB Analyzer User Manual 2-2 © National Instruments Corporation
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File»Open Capture File
Choosing Open Capture Display from the File menu in the main window 
opens a previously saved window of captured GPIB events as an inac
display. Filenames for GPIB analyzer capture files typically use the .CAP 
extension.

File»Exit
Choosing Exit  from the File menu in the main window closes the GPIB 
analyzer application. The analyzer prompts you to save any capture dis
that contains unsaved GPIB events. The current settings for capturing
triggering are saved automatically, and they are automatically loaded 
next time you start the GPIB analyzer.

Settings»Change Settings
Choosing Change Settings from the Settings menu in the main window 
opens the Settings configuration dialog box so that you can change the 
settings used for capturing GPIB events and triggering on specific GP
events. See the Settings Configuration section, later in this chapter, for 
more information.

Settings»Load Settings
Choosing Load Settings from the Settings menu in the main window 
opens a file of previously saved settings to be used for capturing GPIB
events and triggering on specific GPIB events. Filenames for GPIB 
analyzer settings typically use the .SET  extension.

Settings»Save Settings As
Choosing Save Settings As from the Settings menu in the main window 
allows you to save the current settings used for capturing GPIB events
triggering. Whenever possible, use the .SET  extension for GPIB analyzer 
settings filenames.
© National Instruments Corporation 2-3 GPIB Analyzer User Manual
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Windows Menu
The Windows menu in the main window lists all of the currently open 
GPIB analyzer windows. When you select a window from this menu, it
moves to the front.

Help Menu
The Help menu in the main window accesses the online help for the GP
analyzer. It also accesses information about the analyzer software, su
version number and hardware configuration.

Settings Configuration
To configure capture and trigger settings, select Change Settings from the 
Settings menu in the main window. Figure 2-2 shows the Settings 
configuration dialog box.

Figure 2-2.  Settings Configuration Dialog Box
GPIB Analyzer User Manual 2-4 © National Instruments Corporation
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The configured settings apply only to active capture displays. Notice th
the settings in this window cannot be changed unless capturing and 
triggering are turned off (use the Action window to turn off capturing and 
triggering).

The Retain up to _____ capture events edit control specifies the number
of captured GPIB events that can be kept in the internal capture memo
buffer. When the buffer becomes full, the oldest GPIB events are discar
to make space for new GPIB events.

The Participate in Acceptor Handshake checkbox selects whether the 
GPIB analyzer participates in acceptor handshake on the GPIB. If it is
checked, the analyzer hardware participates in the GPIB handshake a
handshake rate selected from the Handshake rate list box. You can use this 
feature to slow down GPIB transfers to a particular rate or to avoid overf
errors.

The Handshake rate list box selects the rate at which the GPIB analyze
accepts data and command bytes. It is disabled unless Participate in 
Acceptor Handshake is checked. The Maximum  option allows the 
analyzer to accept bytes at the fastest rate possible without causing 
overflow errors. The other options slow down all GPIB transfers to a ra
no greater than that specified.

The Enable Timestamping checkbox enables or disables timestamping 
captured GPIB events by the GPIB analyzer. Timestamp resolution is 
50 ns intervals. When checked, timestamping is enabled and the GPIB
analyzer records the time that has elapsed between each GPIB event
captured.

Capture Stimulus Configuration
The Capture Stimulus group box in the Settings dialog box lets you 
choose the various types of GPIB events to capture.

The Data Transfers checkbox enables the capture of GPIB data bytes.
Both IEEE 488 and HS488 data bytes are captured.

The Command Transfers checkbox enables the capture of GPIB 
command bytes.

The Control Line Transitions  checkbox enables the capture of EOI, ATN
SRQ, REN, and IFC GPIB control line transitions. These lines are use
manage the GPIB interface system.
© National Instruments Corporation 2-5 GPIB Analyzer User Manual
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The Handshake Line Transitions checkbox enables the capture of GPIB
handshake line transitions (NRFD, NDAC, DAV). The handshake lines 
used to control the transfer of both GPIB data and command bytes. 
Selecting this option causes a large amount of GPIB events to be capt
and could cause overflow errors; therefore, select it only when you nee
debug a problem with the handshaking of a particular GPIB device. No
that some handshake line transitions may fall within the 50 ns resolutio
the analyzer, so they might be captured and displayed as a single eve
when you check this box.

The Parallel Poll Responses checkbox enables the GPIB analyzer to 
capture all GPIB parallel poll responses. To delimit the beginning of a 
GPIB parallel poll, the analyzer captures the assertion of ATN and EO
The next capture, after 2 µs, denotes the beginning of the parallel poll 
response. The analyzer then captures data each time the response on a
data line changes. To delimit the end of a GPIB parallel poll, the analy
captures the point at which EOI is unasserted.

For more information about setting the capture stimulus, refer to the sec
Configure the Settings in Chapter 3, How To....

Trigger Condition Configuration
The Trigger Condition  group box in the Settings dialog box lets you 
configure the GPIB data and control lines that define the trigger condit

You can enter the GPIB data lines trigger condition as an ASCII value
the ASCII  edit control, a hexadecimal value in the Hex edit control, or a 
binary value in the D8 to D1 spin controls. Notice that the GPIB data trigge
condition is replicated in all three representations: ASCII, hexadecima
and binary. Notice also that the D8 to D1 spin controls have the added 
feature of letting you select x (don’t care) values for particular GPIB data
lines whose states are not relevant to the GPIB data trigger condition.
example, if you want to configure the GPIB data trigger so that any 
non-ASCII GPIB data causes a trigger, set D8 to 1 and set D7, D6, D5, D4, 
D3, D2, and D1 to x.

You can enter the GPIB control lines trigger condition for each of the GP
control lines using the spin controls for EOI , ATN , SRQ, REN, IFC , 
NRFD, NDAC, and DAV. Notice that the x value (don’t care) can be 
chosen for GPIB control lines whose state is not relevant to the trigger
condition.
GPIB Analyzer User Manual 2-6 © National Instruments Corporation
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Configuration of Other Trigger Settings
Immediately below the Trigger Condition  group box in the Settings 
dialog box are the controls that allow you to configure the other trigge
settings. Three of these controls are spin controls.

The spin control on the left configures how to capture data around the 
trigger point. The choices are Capture around first trigger point  and 
Capture indefinitely after trigger point . If you select Capture around 
first trigger point , capture is stopped at a specified point after the first 
trigger is noticed, and the three controls below that spin control are enab
These controls are the Thumb denotes first trigger point slider control, 
the events before trigger edit control, and the events after trigger edit 
control. These three additional controls specify the exact location in th
capture buffer for the first trigger point. If you select Capture indefinitely 
after trigger point , these three controls are disabled and capture contin
even after the trigger condition is noticed.

The two spin controls on the right side below the Trigger Condition  group 
box configure the number of triggers that get recorded and whether be
sounds occur when the trigger condition is noticed. If you select Trigger 
on first occurrence of condition, a single trigger is recorded in the captur
buffer. If you select Trigger on all occurrences of condition, every 
instance of the trigger condition is recorded in the capture buffer. To 
configure beeping that you want to accompany trigger conditions, sele
Do not sound a beep on any trigger, Sound a beep on first trigger point, 
or Sound a beep on all trigger points.

For more information about selecting the trigger settings, refer to the 
Configure Trigger Settings section of Chapter 3, How To....

Exiting the Settings Dialog Box
Clicking on the OK  button in the Settings dialog box saves the changes 
made to the settings and closes the window. These settings are used th
time you start capturing and/or triggering. If you want to save these sett
to a file for later use, choose Save Settings As in the Settings menu of the 
main window.

Clicking on the Cancel button cancels the changes made to the settings 
closes the window.

Clicking on the Default button restores the settings to match the defaul
values, without closing the window.
© National Instruments Corporation 2-7 GPIB Analyzer User Manual
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Action Window
The Action window contains controls you can use to turn capturing and
triggering on and off. The Action window, shown in Figure 2-3, is always
open. If the window is hidden, use Windows»Action Window to bring it 
to the front.

Figure 2-3.  Action Window

When the GPIB analyzer application is started, capture and trigger are
both off.

Clicking on the Capture button causes the analyzer to begin capturing 
GPIB events into the active capture display. Data is captured accordin
to the current capture configuration settings. Triggering is not enabled

Clicking on the Capture & Trigger  button causes the analyzer to begin 
capturing GPIB events into the active capture display and monitoring f
trigger conditions. Data is captured according to the current capture 
configuration settings, and triggers are monitored according to the cur
trigger configuration. The capture and trigger configuration can be 
modified using the settings configuration described in the Settings 
Configuration section, earlier in this chapter.

Clicking on the Off  button causes the analyzer to stop capturing GPIB 
events and stop monitoring for trigger conditions.

Notice the following capabilities concerning captures:

• You can switch back and forth between Capture and Capture & 
Trigger  during the capture without losing data. 

• The GPIB analyzer timer resolution is 50 ns, so the fastest rate of
capturing GPIB events possible is one GPIB event every 50 ns.

• You can view multiple capture displays simultaneously.
GPIB Analyzer User Manual 2-8 © National Instruments Corporation
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Bus Monitor Window
The Bus Monitor window allows you to monitor and control each of the
16 GPIB data and control lines. It also allows you to accept GPIB data,
byte at a time. The Bus Monitor window, shown in Figure 2-4, is always
open. If the Bus Monitor window is hidden, use Windows»Bus Monitor 
to bring it to the front.

Figure 2-4.  Bus Monitor Window

The state of the GPIB data and control lines is displayed on the row o
LEDs and the upper ASCII  and Hex edit controls. You can alter the value
of the GPIB data and control lines using the row of binary switches and
lower ASCII  and Hex edit controls.

You can enter the GPIB data value as an ASCII value in the ASCII  edit 
control, a hexadecimal value in the Hex edit control, or a binary value in 
the 8 to 1 binary switches. Notice that the GPIB data value is replicated
all three representations: ASCII, hexadecimal, and binary.

You can enter the GPIB control value using the EOI , ATN , SRQ, REN, 
IFC , NRFD, NDAC, and DAV  binary switches. The up position 
corresponds to the assertion of the line.

Clicking on the Unassert Lines button moves all of the binary switches to
the down (unasserted) position and disables the Accept Byte button.

Clicking on the Enable Accept Byte button prepares the analyzer to acce
either GPIB data or command bytes, one byte at a time, and changes
button title to Disable Accept Byte. The analyzer unasserts NRFD and 
asserts NDAC. When another GPIB device on the bus asserts the DAV
signal, indicating that data is available, clicking on the Accept Byte button 
accepts the byte and prepares for the next byte. Enabling this feature 
disables the manual binary switches for the NRFD and NDAC control lin
When finished accepting data, clicking on the Disable Accept Byte button 
releases control of the handshaking lines.
© National Instruments Corporation 2-9 GPIB Analyzer User Manual
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The Accept Byte button causes the analyzer to examine the state of th
DAV line to determine whether another GPIB device is trying to send a
byte. If DAV is unasserted, clicking on Accept Byte has no effect because
no data is available to be accepted. If DAV is asserted, clicking on Accept 
Byte accepts a single byte of GPIB data by automatically toggling NRF
and NDAC in the proper sequence. Before you can use this button, yo
must click on the Enable Accept Byte button in the Bus Monitor  window.

Capture Display Window
The Capture Display window displays captured GPIB events. You can
have more than one capture display open at one time, and capture dis
can be either active or inactive. Active capture displays show GPIB eve
as they are being captured. Inactive capture displays show previously
captured events, so that they are unaffected by newly captured GPIB 
events.

To open an active Capture Display window, choose New Capture 
Display from the File menu in the main window. To open an inactive 
Capture Display window, choose Open Capture File from the File menu 
in the main window. You can also use the Switch to Inactive (Active) 
Display button in an active (or inactive, respectively) Capture Display 
window to switch back and forth between the two types of Capture 
Display windows. Figure 2-5 shows an example of an inactive Capture 
Display window.
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Figure 2-5.  Capture Display Window (Inactive)

Menu Choices from a Capture Display
Choosing Save As from the File menu saves the GPIB events in the captu
display to a file. Both inactive and active (provided capture is turned o
capture displays can be saved. Whenever possible, use the .CAP extension 
for GPIB analyzer capture files.

Choosing Print  from the File menu prints the contents of an inactive 
capture display to a selected printer.

Choosing Export  from the File menu saves the GPIB events in an inactiv
capture display to an ASCII text file, which can be imported into other 
applications such as word processors. You cannot import the ASCII fil
back into the GPIB analyzer.

Choosing Close from the File menu closes the Capture Display window. 
The analyzer program prompts you to save any unsaved GPIB events

The Help menu accesses the online help for the GPIB analyzer.
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Capture Settings in a Capture Display
The Capture Settings group box contains information on the capture 
settings configuration that was defined when the capture was made. 
It contains the following items:

• The Stimulus field lists the capture stimuli (as defined by the setting
configuration) used during capture of the GPIB events in the captu
display.

• The Capture size field lists the capture buffer size (as defined by th
settings configuration) used during capture of the GPIB events in 
capture display.

• The Handshake rate field lists the value of the handshake rate 
(as defined by the settings configuration) used during capture of th
GPIB events in the capture display.

Markers & Statistics in an Inactive Capture Display
The Markers & Statistics group box provides capture statistics based o
various markers in the capture buffer. In addition to Begin, End, and 
Cursor markers, you can add markers (M0, M1, M2, and so on) to the 
capture buffer by double-clicking on the entry to be marked. The captu
statistics displayed include the Number of capture events between 
markers, the Time elapsed between markers, and the Capture events per 
second for the data between the markers. Notice that markers and stati
are available only in inactive Capture Display windows.

The From box is used to select the beginning marker used to calculate
capture statistics.

The To box is used to select the ending marker used to calculate the cap
statistics.

The Go To box allows you to go to a particular marker in the capture 
display.

Controls in a Capture Display
The controls in a Capture Display window include Find, Find Next, and 
Switch to Inactive/Active Display buttons and a Display Mode spin 
control.

Click on the Find button to open the Find dialog box, which you can use 
to specify search criteria for finding a particular GPIB event in an inact
Capture Display window.
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Click on the Find Next button to search for the next occurrence of your
search criteria in the inactive capture display. This button is disabled if 
have not yet entered your search criteria in the Find dialog box.

Click on the Switch to Active/Inactive Display button to switch between 
active and inactive capture display modes. Active capture displays sho
GPIB events as they are being captured. Inactive displays show previo
captured GPIB events. With inactive displays, you can place markers, v
statistics about the captured GPIB events, and search for specific GPI
events. Switching from inactive to active display deletes all captured G
events and markers, but the analyzer prompts you to save your data b
switching to an active display.

The Display mode spin control chooses the display mode used for the 
captured GPIB events. In Detailed display mode, captured GPIB events ar
shown one per line. In Summarized display mode, multiple events can be
shown on each line. Line transitions are displayed on separate lines, b
data and command transfers are grouped on the same line. In both di
modes, data transfers are shown in blue, command transfers are show
green, and control line transitions, handshake line transitions, and par
poll responses are all shown in black.

Capture Data in a Capture Display Window
The capture display shows captured GPIB events, markers, timestam
and helpful mnemonics. It can also show control line and handshake l
transitions. If the line name is followed by an up arrow, the line went fro
unasserted to asserted. If the line name is followed by a down arrow, 
line went from asserted to unasserted. This field might also display an
overflow error message if the FIFO is full and events are lost.

For specific information about how to interpret the capture display, refe
to the Analyze Captured Data section of Chapter 3, How To..., or to 
Appendix B, Capture Display Mnemonics.
© National Instruments Corporation 2-13 GPIB Analyzer User Manual



Chapter 2 GPIB Analyzer Features

h 
 

 
 

data 

 the 

trol 
Search Capability
The Find and Find Next buttons in the capture display allow you to searc
for specific GPIB data and control line patterns, data strings, or trigger
points in an inactive capture display.

To do a new search, click on the Find button in an inactive capture display
to bring up a Find dialog box similar to the one shown in Figure 2-6. To
repeat the search, click on the Find Next button in the inactive capture 
display.

Figure 2-6.  Find Dialog Box

To find a trigger point in the Capture Display window, check the Find 
Trigger  checkbox, and then click on the Find button.

To find a particular data and control line pattern, set the pattern of the 
lines using either the ASCII  or Hex edit controls or the D8 to D1 spin 
controls (for binary values), and set the pattern of the control lines using
EOI , ATN , SRQ, REN, IFC , NRFD, NDAC, and DAV  spin controls. 
Notice that the spin controls allow you to select 0 (unasserted), 1 (asserted), 
or x (don’t care) for each data and control line. When the data and con
lines have been selected, click on the Find button.
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To find a series of GPIB data and control line patterns, use the Insert 
Above, Insert Below, and Delete buttons to add and remove entries from
the Find String  list box until it contains the desired series of GPIB data a
control line patterns. Click on the Find button to conduct the search.

Use the Search Direction switch to specify the direction to search from th
current cursor position in the capture display.

Click on the Cancel button to cancel the search and close the Find 
dialog box.
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How To...

This chapter describes how to accomplish specific tasks within the GP
analyzer application.

Install the GPIB Analyzer
The GPIB analyzer software is installed along with the other NI-488.2 
software components from the NI-488.2 for Windows CD. To install the 
GPIB analyzer, insert the CD, then choose the Install NI-488.2 Software 
for Windows option from the CD autorun screen.

Figure 3-1.  CD Autorun Screen
lyzer User Manual
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Start the GPIB Analyzer
Launch the GPIB analyzer application from the Measurement & 
Automation Explorer, which is started by selecting Start»Programs» 
National Instruments NI-488.2»Explore GPIB. To start the GPIB 
analyzer, select a GPIB interface under Devices and Interfaces in the left 
window frame, right-click, and select GPIB Analyzer.

Exit the GPIB Analyzer
Choose File»Exit to close the GPIB analyzer application. The analyzer
prompts you to save any capture display that contains unsaved GPIB 
events. The current settings for capturing and triggering are saved 
automatically, and they are automatically loaded the next time you star
GPIB analyzer.

Start and Stop Capture of Data
To begin capturing data, complete the following steps:

1. Configure the capture settings and trigger conditions using Settings» 
Change Settings.

2. If an active display is not already open, open a new Capture Display 
window using File»New Capture Display.

3. Bring the Action window to the front using Windows»Action 
Window.

4. Click on the Capture or Capture & Trigger  button in the Action 
window to begin capturing data.

To stop capturing new data, click on the Off  button in the Action window.
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Monitor or Participate in GPIB Activity

View/Change the State of GPIB Data and Control Lines
You can view or change the state of the GPIB data and control lines fr
within the Bus Monitor window.

The state of the GPIB data and control lines is displayed on the row o
LEDs and the upper ASCII  and Hex edit controls. You can alter the value
of the GPIB data and control lines using the row of binary switches and
lower ASCII  and Hex edit controls.

You can enter the GPIB data value as an ASCII value in the ASCII  edit 
control, a hexadecimal value in the Hex edit control, or a binary value in 
the 8 to 1 binary switches. Notice that the GPIB data value is replicated
all three representations: ASCII, hexadecimal, and binary.

You can enter the GPIB control value using the EOI , ATN , SRQ, REN, 
IFC , NRFD, NDAC, and DAV  binary switches. The up position 
corresponds to the assertion of the line.

To accept a byte of data on the bus, use the NRFD and NDAC binary 
switches to simulate the IEEE 488 handshake, or use the Accept Byte 
button, which automatically toggles NRFD and NDAC in the correct 
sequence. The Accept Byte button is enabled by clicking on the Enable 
Accept Byte button.

If you are using the Bus Monitor to assert GPIB lines, do not use the 
NI-488.2 ibfind  or ibdev  functions. These functions unassert the line
on the bus, even though the switches in the Bus Monitor window show that 
the lines are asserted. If you encounter this problem, click on the Unassert 
Lines button and avoid using the ibfind  or ibdev  functions.

Accept a Single Byte
To accept a single byte of data on the GPIB, first click on the Enable 
Accept Byte button in the Bus Monitor  window. Then, click on the 
Accept Byte button in the Bus Monitor window. This action automatically 
toggles the NRFD and NDAC lines in the correct IEEE 488 handshaki
sequence to accept a single byte. If you disable the Accept Byte feature, 
you can control the NRFD and NDAC lines manually using the binary 
switches in the Bus Monitor window.
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If you try to accept a byte when no GPIB device is currently trying to sou
a byte (DAV unasserted), toggling the handshake lines or clicking on 
Accept Byte has no effect.

View Previously Captured Data
To open a Capture Display window to view previously saved GPIB 
events, choose File»Open Capture File.

Configure the Settings
Settings are configured with the Settings configuration dialog box, which 
you can open by choosing Settings»Change Settings.

Configure Capture Settings
Complete the following steps to configure the capture settings:

1. Click on the Off  button in the Action window. (Selecting 
Windows»Action Window brings the Action window to the front.)

2. Open the Settings dialog box by choosing Settings»Change Settings.

3. Configure the capture settings. Refer to the Settings Configuration 
section of Chapter 2, GPIB Analyzer Features, for details on all the 
capture settings you can configure.

4. When you are finished making changes, click on OK  in the Settings 
dialog box.

You can save your capture settings by choosing Settings»Save Settings As 
and reload them by choosing Settings»Load Settings.

Configure Trigger Settings
Complete the following steps to configure the trigger settings for your 
capture:

1. Click on the Off  button in the Action window. (Selecting 
Windows»Action Window brings the Action window to the front.)

2. Open the Settings dialog box by choosing Settings»Change Settings.

3. Configure the trigger settings. Refer to the Trigger Condition 
Configuration and Configuration of Other Trigger Settings sections of 
Chapter 2, GPIB Analyzer Features, for details on all the trigger 
settings you can configure.
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4. When you are finished making changes, click on OK  in the Settings 
dialog box.

You can save your trigger settings by choosing Settings»Save Settings As 
and reload them by choosing Settings»Load Settings.

To use the configured trigger settings, start capture using the Capture & 
Trigger  button in the Action window, instead of the Capture button.

Timestamp Capture Events
Timestamping shows you the elapsed time between GPIB events capt
by the GPIB analyzer. The timestamp information appears in the timesta
column of the capture display.

To enable timestamping, check the Enable Timestamping checkbox in the 
Settings dialog box.

Do a Non-Intrusive Capture
To prevent the GPIB analyzer from participating in acceptor handshak
uncheck the Participate in Acceptor Handshake checkbox in the 
Settings dialog box. If this checkbox is checked, the analyzer participa
in all handshaking on the GPIB. You might want to select this checkbox
slow down the GPIB transfers or to avoid overflow errors.

Avoid Overflow Errors
An overflow error occurs when the GPIB analyzer FIFO hardware buff
fills up with GPIB events faster than the software can receive them. If t
happens, an error message with asterisks and the word “OVERFLOW
appears in the capture display, as shown in Figure 3-2.
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Figure 3-2.  Overflow Error

If an overflow error occurs, one or more GPIB events have been lost. Y
can usually avoid overflow errors by making one of the following chang

• Check the Participate in Acceptor Handshake checkbox in the 
Settings dialog box, and set the Handshaking rate to Maximum . 
This configuration causes the analyzer to hold off when the FIFO 
almost full. It prevents high speed GPIB data transfers when the FI
is almost full, which can be a common cause of overflow errors.

• Uncheck the Handshake Line Transitions checkbox in the Settings 
dialog box. If this option is selected, you might capture up to six tim
as many GPIB events as when choosing to capture only data and
command transfers. The reason for this is that when you enable th
capture of handshake line transitions, you start getting GPIB even
such as NDAC↑ and NRFD↓, which reflect the multiple changes tha
occur to the states of the GPIB handshake lines for each byte 
transferred on the GPIB. This high volume of events is likely to cau
overflow errors.
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• Uncheck the Enable Timestamping checkbox in the Settings dialog 
box. If you do not need to see the timestamping information, disabl
this option can reduce the amount of data transferred from the FIF
and reduce the possibility for overflow errors.

• Uncheck the Control Line Transitions  checkbox in the Settings 
dialog box. Some GPIB devices may toggle the control lines 
incorrectly, and overflow errors could result.

• Close all active capture displays while capturing. The analyzer 
captures GPIB events more efficiently if they do not need to be 
displayed immediately.

• Increase the Retain up to _____ capture events value in the Settings 
dialog box. This field specifies the maximum number of capture eve
retained in the capture buffer.

Save and Reload Capture/Trigger Settings
The analyzer uses the current capture and trigger settings until you ch
them again and automatically saves them when you exit the analyzer 
program. If you want to save the current settings for later use, use 
Settings»Save Settings As. Whenever possible, use the .SET  extension for 
analyzer settings filenames.

To load a file of previously saved settings, use Settings»Load Settings.

Analyze Captured Data
After you have captured GPIB events, you are ready to view and inter
the captured data, calculate statistics, search for specific capture even
print the captured data, or save the captured data.

View the Captured Data
You can view the captured GPIB events in either detailed display mod
summarized display mode. With detailed display mode, captured GPIB
events are shown one per line. In summarized display mode, multiple 
events are combined on single lines. Line transitions are displayed on
separate lines, but data and command transfers are grouped on the s
line. In either display mode, lines are color coded based on the type of e
captured. Table 3-1 shows the color coding scheme.
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Read the Timestamp Column
In detailed mode, where each line represents a single capture event, t
timestamp value represents the time elapsed between the event on tha
and the event on the previous line. If you want to determine the time 
elapsed between the capture of the first event and the fifth event, add u
timestamp values on the second, third, fourth, and fifth lines. Alternative
you can switch to an inactive display using the Switch to Inactive Display 
button, and put markers on the first and last event of interest, then use
From and To fields in the Markers & Statistics group box to have the 
GPIB analyzer calculate a Time elapsed value for you.

In summarized mode, where more than one event can be present on a
the timestamp value represents the time elapsed between the first eve
that line and the first event on the previous line.

The timestamp column in the capture display shows the timestamp in 
minute, second, millisecond, microsecond, and nanosecond notation. I
timestamp exceeds 60 minutes, the timestamp is shown in an hour, mi
and second notation. The abbreviations used for the various time scale
listed in Table 3-2. The smallest recordable timestamp is 50 ns.

Table 3-1.  Color Coding in the Capture Display

Type of Event Color

Data transfers Blue

Command transfers Green

Control line transitions Black

Handshake line transitions Black

Parallel poll responses Black

Trigger event Dotted box

Overflow White

Table 3-2.  Timestamp Abbreviations in the Capture Display Window

Time Unit Abbreviation

Nanoseconds ns

Microseconds us

Milliseconds ms
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Read the Mnemonics Column
Various mnemonics appear in the right column of the capture display 
provide a quick interpretation of the captured GPIB events. The colum
may also show line transitions. If the line name is followed by an up arr
(↑), the line transitioned from unasserted to asserted. If the line name 
followed by a down arrow (↓), the line transitioned from asserted to 
unasserted. Notice that if the analyzer is capturing handshake line 
transitions, the assertion of DAV represents a GPIB data byte or comm
byte. For a detailed list of the mnemonics and their meanings, refer to
Appendix B, Capture Display Mnemonics.

Search for a Capture Event
To search for a specific GPIB event within a capture display from the 
current cursor location, complete the following steps:

1. Switch to an inactive Capture Display window.

2. Click on the Find button.

3. Enter your search criteria in the Find dialog box.

To find a trigger point in the Capture Display window, check the Find 
Trigger  checkbox.

To find a particular data and control line pattern, set the pattern of
data lines using either the ASCII  or Hex edit controls or the D8 to D1 
spin controls (for binary values), and set the pattern of the control li
using the EOI , ATN , SRQ, REN, IFC , NRFD, NDAC, and DAV  spin 
controls. Notice that the spin controls allow you to select 0 
(unasserted), 1 (asserted), or x (don’t care) for each data and 
control line.

To find a series of GPIB data and control line patterns, use the Insert 
Above, Insert Below, and Delete buttons to add and remove entries 
from the Find String list box until it contains the desired series of 
GPIB data and control line patterns.

Seconds s

Minutes mi

Hours hr

Table 3-2.  Timestamp Abbreviations in the Capture Display Window (Continued)

Time Unit Abbreviation
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Use the Search Direction switch to specify the direction to search 
from the current cursor position in the capture display.

4. Click on the Find button in the Find dialog box. This action 
automatically closes the Find dialog box and takes you from the 
current cursor position to the first GPIB event in the capture displa
that matches your search criteria.

To find the next occurrence, click on the Find Next button.

Mark Capture Events to Show Statistics
Markers are allowed only in inactive capture displays. All inactive captu
displays contain at least two markers: Begin and End. Single-clicking 
places the cursor in a capture display. Double-clicking places markers
capture display and removes placed markers. Markers are labeled M0, M1, 
M2, and so on, as they are created.

After you have placed your markers, you can use the From and To controls 
in the Markers & Statistics group box to examine statistics about the 
captured data.

If you are using summarized display mode, you might have more than
marker for each line. In this case, the letter M  appears in the marker 
column. You can click on the M  several times to see each marker for 
that line.

Print and Save Captured Data
To print the contents of an inactive Capture Display window, use 
File»Print . You can print the entire capture display or limit the printing 
captured events between particular markers.

Both inactive and active (if capturing is turned off) capture displays can
saved to a file. To save the data in a Capture Display window, use 
File»Save As. Whenever possible, use the .CAP extension for saving 
capture display files. Captured data is saved in an analyzer-specific fo
and can be reopened as an inactive capture display.

You can also export an inactive capture display as an ASCII text file to
another application, such as a word processor. Use File»Export to export 
the captured data. You can export captured data as text in both detailed
summarized formats. You cannot import the ASCII text file back into th
GPIB analyzer.
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Tutorial

This chapter contains a hands-on tutorial to help you practice using th
different features of the GPIB analyzer application.

Before you start the tutorial, check the following:

• Make sure that the NI-488.2 software, GPIB analyzer software, an
GPIB hardware are installed on your computer. For installation 
instructions, refer to the section Install the GPIB Analyzer in 
Chapter 3, How To....

• Disconnect all GPIB cables from your GPIB hardware.

Part 1. Capture and View New Data

1. Launch the GPIB analyzer application from the Measurement & 
Automation Explorer by selecting Start»Programs»National 
Instruments NI-488.2»Explore GPIB. To start the GPIB analyzer, 
select a GPIB interface under Devices and Interfaces in the left 
window frame, right-click, and select GPIB Analyzer.

When you open the application, a new Capture Display window and 
the Action window are visible.

2. Choose Settings»Change Settings to bring up the Settings 
dialog box.

3. In the Settings dialog box, click on the Default button to reset to the 
default settings.

4. In the Capture Stimulus section, choose to capture the following 
stimuli: data transfers, command transfers, control line transitions, 
parallel poll responses. Do not select handshake line transitions.

5. Click in the Retain up to _____ capture events box and change the 
setting to 60,000 capture events.

You do not need to change the trigger settings because this part o
tutorial does not use triggering.
lyzer User Manual
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The Settings dialog box should now look like the following screen.

6. Click on OK  to use these settings.

You can save these settings for later use. To save them, choose 
Settings»Save Settings As from the main window. To retrieve saved
settings, choose Settings»Load Settings from the main window.

7. If the Action window is hidden, bring it to the foreground by choosin
Windows»Action Window from the main window. 

8. Click on the Capture button in the Action window. The analyzer is 
ready to capture GPIB events.

9. Open the Interactive Control utility from the Measurement & 
Automation Explorer, which is started by selecting Start»Programs» 
National Instruments NI-488.2»Explore GPIB. To start Interactive 
Control, select a GPIB interface under Devices & Interfaces in the left 
window frame, right-click, and select Interactive Control .

10. At the prompt, enter $ "c:\Program Files\National 

Instruments\NI-488.2\Analyzer\Tutorial.txt"  to run the 
tutorial script. (The path to the file might be different if you did not u
the default installation directory when you installed the GPIB analyz
software.) Wait until the script has executed. The NI-488.2 comman
GPIB Analyzer User Manual 4-2 © National Instruments Corporation
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in this script file write data on the GPIB, and the analyzer portion o
the GPIB hardware captures the data.

11. At the :  prompt, type quit  and press <Enter> to exit the Interactive
Control utility.

12. Switch back to the GPIB analyzer, and click on Off  in the Action 
window to stop the capture.

13. In the active Capture Display window, use the scroll bar to go to the
beginning of the capture file.

The Capture Display window should look like the following screen.

By default, the capture display is in detailed mode, which shows o
GPIB event per line. This mode shows the greatest amount of det
including the status of each GPIB line and helpful mnemonics. In t
display, you can see that the tutorial script file issued the following
commands: clear the GPIB interface, address a device to listen, a
write data to the device.

14. Change the display mode from detailed to summarized by clicking
the arrow beside the Display Mode spin control. Summarized display
mode is often easier to read if you do not need to see one event per
but it displays less information.
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Part 2. Capture and View New Data 
with a Trigger Condition

1. Choose Settings»Change Settings to bring up the Settings 
dialog box.

2. In the Capture Stimulus section, choose to capture data transfers a
command transfers. Unselect the checkboxes for the other types 
transfers. This restricts the analyzer to capture only data and comm
transfer events on the bus.

3. Click on Maximum  in the Handshake rate box to see your choices. 
Then, click on the 1 Kbyte/s option. This handshake rate slows dow
the GPIB transfers.

4. Choose to retain up to 50 capture events.

5. Select the Enable Timestamping box to turn on the timestamping 
feature.

6. In the Trigger Condition  section, enter 1 in the ASCII  edit control 
and notice the corresponding changes in the Hex box and the D8 to D1 
toggle switch boxes.

7. Use the binary switches to set the ATN  line to 0, NRFD to 0, 
NDAC to 1, and DAV to 1. Leave the EOI , SRQ, REN, and IFC  lines 
set as don’t care (x).

8. Make sure Capture around first trigger point shows up as the current
setting. This option stops the capture when a certain number of ev
have been captured after the trigger point. Use the Thumb denotes 
first trigger point  to specify how many events to capture before an
after the trigger point. Move the slider below Thumb denotes first 
trigger point  so that the capture file shows 5 events before the trigg
point and 44 events after the trigger point.

9. Click in the spin control with the words Trigger on first occurrence 
of condition to see your choices. Select Trigger on all occurrences of 
condition. This option captures and displays all occurrences of the
trigger condition.
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10. Click in the spin control with the words Do not sound a beep on any 
trigger to see your choices, then select Sound a beep on first 
trigger point .

The Settings dialog box should look like the following screen.

11. Click on OK  to use these settings.

12. Bring the Action window to the front by choosing Windows»Action 
Window. Click on the Capture & Trigger  button. The analyzer is 
ready to capture data and look for the trigger condition specified in 
Settings dialog box.

13. Bring the Capture Display window to the front, and notice that the 
changes you made in the Settings dialog box are shown in the Capture 
Settings section because you clicked on Capture & Trigger .

14. Open the Interactive Control utility from the Measurement & 
Automation Explorer, which is started by selecting Start»Programs» 
National Instruments NI-488.2»Explore GPIB. To start Interactive 
Control, select a GPIB interface under Devices & Interfaces in the left 
window frame, right-click, and select Interactive Control .

15. At the prompt, enter $ "c:\Program Files\National 

Instruments\NI-488.2\Analyzer\Tutorial.txt"  to run the 
tutorial script again. (The path to the file might be different if you d
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not use the default installation directory when you installed the GP
analyzer software.)

16. Switch back to the analyzer program, and click on Off  in the Action 
window to stop the capture.

17. In the active Capture Display window, click on Switch to Inactive 
Display.

18. If necessary, switch to detailed display mode. Scroll to the top of t
capture display.

The Capture Display window should look something like the 
following screen.

The trigger points are enclosed in dotted boxes and the display sh
five events before the first trigger point.

19. Choose File»Save As.

20. Enter tutor2.cap  as the capture filename and click on Save. Notice 
that tutor2.cap  appears on the title bar of the Capture Display 
window.

21. From the main File menu, choose Exit  to quit the analyzer application.
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Part 3. Search for Data in a Capture Display

1. Open the GPIB analyzer application.

2. Choose File»Open Capture File.

3. In the dialog box, enter tutor2.cap  to retrieve the capture file that 
you saved in part 2 of this tutorial, and click on OK . The capture file 
is automatically opened as an inactive display.

4. Click on the Find button in the Capture Display window to bring up 
the Find dialog box.

5. Select the Find Trigger  checkbox to search for the captured trigger
event, ASCII 1, which was the trigger point specified in part 2 of th
tutorial. The trigger pattern is displayed in the Input Bus State field 
and the Find String  field.

6. Click on Find to start the search. The result will be highlighted as 
shown in following screen. ASCII 1 appears in the “A” column of th
highlighted row.
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7. Click on the Find button to bring up the Find dialog box.

8. Unselect the Find Trigger  checkbox.

9. In the Input Bus State section, enter 5 in the ASCII  edit control.

10. Click on Find to locate the search pattern.

11. Return to the Find dialog box.

12. To create a string to search for, choose Insert Below to enter another 
pattern in the Input Bus State.

13. Enter 6 in the ASCII  edit control to indicate the second pattern in th
search.

14. Choose Insert Below again, but this time enter 7. These characters 
form a string (“567”) that the analyzer searches for in the capture f
The Find dialog box should look like the following screen.

15. Click on Find to search for the string “567”.

16. The first character of the matched search string, “5”, will be 
highlighted as shown in the following screen.
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17. Click on the Find Next button to continue your search. The next 
successful search result will be highlighted.

Part 4. Show Statistics for Captured Data 
Use the tutor2.cap  capture file that you obtained in part 2 and opened
part 3 of this tutorial.

1. In the Capture Display window, create a marker at the line containin
the ASCII character “A” by double-clicking on that line. The marke
M0 appears in the marker column of that line.

2. Create another marker at the line containing the letter “Z”. M1 appears 
in the marker column of that line.

3. Click on the word Begin in the From spin control in the Markers & 
Statistics group box to see your choices, then select M0, the marker 
for the letter “A”.

4. Choose M1 for the To list box.

The analyzer calculates and displays statistics as shown in the 
following screen.
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The capture display statistics show the total number of captured ev
from marker M0 to marker M1. The Time elapsed statistic shows you 
the total time to transfer this block of data. The Capture events per 
second box shows system performance during this period of time.

5. Choose M0 in the Go To list box to highlight the line with the letter 
“A” again.

Part 5. Print and Export a Capture File
This part of the tutorial is continued from part 4. Use the tutor2.cap  
capture file that you used in part 4.

1. Choose File»Print .

2. In the print dialog box, select M0 for the From Marker  and M1 for 
the To Marker .

3. Click on OK . The portion of the capture display from M0 to M1 will 
be printed. If you want to print the entire capture display, choose Begin 
for the From Marker  and End for the To Marker .
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4. Save the capture file as ASCII text by choosing File»Export.

5. Enter sample.txt  in the export dialog box, and click on Save. You 
can view the exported file in a text editor, but you cannot import it ba
to the analyzer.

6. From the File menu in the main window, choose Exit  to quit the 
analyzer application.
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Examples

This chapter contains several examples that illustrate how to use the G
analyzer application to solve your IEEE 488 problems.

Example 1. Slow Communication

Description of Problem
A technician is running a GPIB application in which an AT-GPIB/TNT+
interface is communicating with a multimeter. In the application, the 
Controller instructs the instrument to reset to its default settings, meas
Ohms, and return a reading. The application seems to be running slow
and the technician wants to determine the cause of the slow performa

Setting up the GPIB Analyzer 
By using the timestamping feature of the GPIB analyzer, the technician
determine what is causing the application to run slowly. In the Settings 
dialog box of the GPIB analyzer, he chooses the following settings:

• Capture data transfers, command transfers, and control line transi

• Retain 10,000 events

• Timestamping feature enabled

• Do not participate in acceptor handshake
lyzer User Manual
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The Settings dialog box looks like the following screen.

The technician clicks on OK  to close the Settings dialog box and clicks on 
Capture in the Action window to start capture, then runs his application
After the application executes, he switches back to the analyzer and c
on Off  in the Action window to stop capture.
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Reading the Capture Display
The following picture shows the resulting capture display.

The technician has chosen Summarized display mode. In the capture 
display, he sees the string “RST; OHMS; VAL1?”, which instructs the 
multimeter to reset, measure Ohms, and send a reading to the Contro
The next string, “+150.38E+0” is the reading from the device. The 
technician switches back to detailed display, and after he places the ma
in the capture display, he selects various markers in the From and To list 
boxes. For example, he calculates the time the device takes to start se
its measurement, which is 1 s, 81 ms, 429 µs, and 450 ns. The statistics tha
the technician sees reveal that the system performance is satisfactory
the instrument is slow in returning a measurement.
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Example 2. A Service Request Problem

Description of Problem
A test engineer has a GPIB system with two GPIB devices connected.
engineer expects that when a device requests service, it asserts the S
line. He has specified in his application that when SRQ is asserted, th
Controller serial polls the active devices to determine which device is 
requesting service and then takes the appropriate action. In this partic
application, the time between the device asserting SRQ and the devic
receiving service is too long, so the engineer wants to check the SRQ
serial poll response of his system.

Setting up the GPIB Analyzer
By using the timestamping feature of the GPIB analyzer, the engineer
able to view the service request process and measure response times
configures the analyzer to trigger at the assertion of SRQ and to captu
GPIB events afterwards. By observing the captured events with 
timestamping information, he learns more about the sequence of even
during a serial poll of his system.

In the Settings dialog box of the GPIB analyzer, the engineer chooses 
following settings:

• Capture data transfers, command transfers, and control line transi

• Capture 500 events after the trigger point

• Trigger condition set to SRQ asserted (SRQ = 1) and all other line
equal to “x”

• Timestamping feature enabled

• Capture around the first trigger point
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The Settings window looks like the following screen.

The engineer chooses Capture & Trigger  in the Action window and runs 
his application program.
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Reading the Capture Display
The resulting capture with two added markers (M0 and M1) looks like the 
following screen.

The marker M0 appears on the first line, which shows the assertion of t
SRQ line. The engineer places a marker M1 where the Controller starts the
serial poll by sending the Unlisten command (UNL). By choosing M0 in 
the From list box and M1 in the To list box to calculate the Time elapsed 
statistic, he sees that the Controller takes 851 ms, 449 µs, and 200 ns to 
respond to the serial poll.

The Controller sends its listener address (LA0 in this case) and the se
poll enable (SPE) command. The Controller sends TA1 so that the firs
device can talk, then unasserts ATN and reads the status byte (0x00) 
the device. By reading the timestamp information on the line where the 
device sends 0x00, the engineer knows that the device takes 103 ms,µs, 
and 40 ns to send its status byte.

Device 1
Response Time

Device 2
Response Time
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Because the first device is not the one requesting service (because its 
byte does not have bit 6 set), the Controller addresses the second dev
talk. The Controller then reads the device’s status byte (0x40), which 
indicates that it is requesting service. By reading the timestamp informa
on the line where the second device sends 0x40, the engineer sees th
device takes only 1 µs and 50 ns to send its status byte.

Because the response time of the second device polled is shorter than
first device, the engineer changes his application so that the Controlle
always polls the faster device first. If the faster device is the one reques
service, the Controller will not need to poll the slower device.

Example 3. Device Not Responding

Description of Problem
A programmer has written an NI-488.2 application , but her device is n
responding to the application.

Setting up the GPIB Analyzer
The programmer configures the analyzer so that she can check for 
communication problems. In the Settings dialog box of the GPIB analyzer,
she chooses the following settings:

• Capture data transfers, command transfers, and control line transi

• Retain 60,000 events

• Participate in handshaking and transfer rate set to maximum

• Timestamping disabled
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The Settings dialog box looks like the following screen.

The programmer chooses Capture in the Action window and captures the 
sequence of events on the GPIB. She then clicks on Off  in the Action 
window of the analyzer.
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Reading the Capture Display
The resulting capture display looks like the following screen.

In this example, the Controller does not seem to be sending any data b
In her application, the programmer set up the device to have primary 
address 3 and secondary address 96. She notices, however, that at th
containing the marker M0, the Controller configures the device to be a 
Listener at primary address 3 with no secondary address. The device 
not responding because the Controller is not addressing it correctly. 
The programmer corrects her application and runs the capture again. 
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Controller can now write to the device, and the capture display looks li
the following screen.

Example 4. Timeout Error During a Read

Description of Problem
A programmer’s application returns a timeout error while waiting to 
receive data from a device.

Setting up the GPIB Analyzer
The programmer configures the analyzer so that he can examine the G
activity during a read from the device. In the Settings dialog box of the 
GPIB analyzer, he chooses the following settings:

• Capture data transfers, command transfers, and control line transi

• Retain 60,000 events

• Participate in handshaking and transfer rate set to maximum

• Timestamping disabled
GPIB Analyzer User Manual 5-10 © National Instruments Corporation



Chapter 5 Examples

ks on 
The Settings dialog box looks like the following screen.

The programmer chooses Capture in the Action window and captures the 
sequence of events as the device sends data on the bus. He then clic
Off  in the Action window of the analyzer.
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Reading the Capture Display
The resulting capture display looks like the following screen.

This capture display shows that the device asserts EOI with the last by
The programmer remembers that he set up his application to expect a
End-of-String character to terminate the data transfer from the device.
changes the program so that it expects the assertion of EOI to terminat
data transfer. The application then runs without an error.
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Common Questions

This appendix answers common questions about the GPIB analyzer.

Why can’t I use the analyzer to monitor an NI-488.2 application which 
uses the NI-488.2 ibln  or FindLstn  command?

You can use the analyzer to monitor an application with these comma
but you cannot select Participate in Acceptor Handshaking in the 
Settings dialog box of the analyzer. Selecting this feature asserts/unass
the NDAC and NRFD lines in response to the Talker’s assertion/unasse
of DAV in the GPIB handshake sequence. Therefore, when you run an
application that executes a FindLstn  or ibln  command, all possible 
GPIB addresses are returned.

How does selecting “Participate in Acceptor Handshake” in the 
Settings dialog box affect the GPIB? 

When Participate in Acceptor Handshake is selected, the analyzer 
circuitry behaves like a GPIB Listener for the duration of the capture a
participates in acceptor handshaking on the GPIB. You can use this fea
to slow down GPIB transfers to a particular rate and to avoid overflow 
errors. 

How do I choose a handshake rate? What does “Maximum” mean?

You can use the handshake rate to slow down the transfer rate on the G
while debugging timing-related problems. Choosing a particular handsh
rate guarantees that the transfer rate on the bus will be less than or eq
that rate. Choosing the Maximum  rate causes the analyzer to respond as
Listener as fast as it can without causing overflow errors.

How do I define a trigger point to capture a command byte such 
as TA0?

In the Settings dialog box, set the data lines of the trigger condition by 
entering either the ASCII or hex equivalent of TA0 or set each of the d
lines independently to represent TA0. Set the ATN, DAV, and NDAC lin
to 1. Set NRFD to 0. The remainder of the control lines should be set t
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This state of the handshake lines is necessary to guarantee that valid d
present on the data lines.

What do the rows of lights and switches in the Bus Monitor window 
represent?

The LEDs represent the state of the bus lines at all times. The toggle 
switches represent the assertion of lines from within the Bus Monitor  
window of the analyzer. If the LED for a particular line is on, and the swi
for that line is off (down position), the line is asserted, but not by the B
Monitor.

What is the difference between active and inactive capture displays?

Active capture displays show GPIB events as they are being captured
other words, active capture displays are windows into the single captu
buffer used to store new GPIB events. Inactive capture displays show 
previously captured GPIB events statically, so that they are unaffected
newly-captured GPIB events. You must make the capture display inac
if you want to use the search or print features.

What do the “Capture Settings” in the Capture Display window mean?

The Capture Settings section of the Capture Display window shows the 
capture settings that were used when the data in the window was capt
They help you interpret the captured data in the Capture Display window. 
They are not necessarily the same as the current capture settings.

How do I use the timestamping information in detailed display mode 
and summarized display mode?

In detailed display mode, where each line can correspond to only one
capture event, the timestamp value represents the time elapsed betwe
event on that line and the previous event. If you want to determine the t
elapsed between the capture of the first event and the fifth event, add u
timestamp values on the second, third, fourth, and fifth lines.

In summarized display mode, where more than one event can be prese
a line, the timestamp value represents the time elapsed between the f
event on that line and the first event on the previous line.

How can I prevent overflow errors?

For detailed information about avoiding overflow errors, refer to the Avoid 
Overflow Errors section in Chapter 3, How To....
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Capture Display Mnemonics

This appendix explains the mnemonics that appear in the capture displ
the GPIB analyzer application.

DAB GPIB data byte captured using the data transfer or 
handshake line transition.

GPIB command bytes captured using the command transfer or hands
line transition:

ACG Addressed command group.
CFE Configuration enable.
DCL Device clear.
GET Group execute trigger.
GTL Go to local.
LA0-LA30 Listen addresses 0-30.
LLO Local lock out.
PPC Parallel poll configure.
PPU Parallel poll unconfigure.
SC0-SC30 Secondary command 0-30*.
SDC Selected device clear.
SPD Serial poll disable.
SPE Serial poll enable.
TCT Take control.
TA0-TA30 Talk addresses 0-30.
UCG Universal command group.
UNL Unlisten.
UNT Untalk.

GPIB parallel poll responses captured using the parallel poll response
capture stimulus:

PP-B Parallel poll is beginning.
PP-E Parallel poll is ending.
PP-R Parallel poll response (occurs between PP-B and PP-

*   If SC appears after a talk or listen address, it is a secondary address. If it appears after a parallel poll configure, it isither a 
parallel poll enable (PPE) or a parallel poll disable (PPD) command. If it appears after configuration enable (CFE), it
cable length for HS488.
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Technical Support Resources

National Instruments offers technical support through electronic, fax, a
telephone systems. The electronic services include our Web site, an F
site, and a fax-on-demand system. If you have a hardware or software
problem, please first try the electronic support systems. If the informat
available on these systems does not answer your questions, contact o
our technical support centers, which are staffed by applications engine
for support by telephone and fax. To comment on the documentation 
supplied with our products, send e-mail to techpubs@natinst.com .

Web Site
The InstrumentationWeb address is http://www.natinst.com . 

From this Web site you can connect to our Web sites around the world
(http://www.natinst.com/niglobal/ ) and access technical suppor
(http://www.natinst.com/support/ ).

FTP Site
To access our FTP site, log in to our Internet host, ftp.natinst.com , as 
anonymous  and use your e-mail address, such as 
yourname@anywhere.com , as your password. The support files and 
documents are located in the \support  directories.

Fax-on-Demand Support
Fax-on-Demand is a 24-hour information retrieval system containing a
library of documents in English on a wide range of technical informatio
You can access Fax-on-Demand from a touch-tone telephone at 
512 418 1111.

E-Mail Support
You can submit technical support questions to the applications enginee
team through e-mail at support@natinst.com . Remember to include 
your name, address, and phone number so we can contact you with 
solutions and suggestions. 
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Telephone and Fax Support
National Instruments has branch offices all over the world. Use the 
following list to find the technical support number for your country. If the
is no National Instruments office in your country, contact the source fro
which you purchased your software to obtain support.

Country Telephone Fax

Australia 03 9879 5166 03 9879 6277

Austria 0662 45 79 90 0 0662 45 79 90 19

Belgium 02 757 00 20 02 757 03 11

Brazil 011 284 5011 011 288 8528

Canada (Ontario) 905 785 0085 905 785 0086

Canada (Québec) 514 694 8521 514 694 4399

Denmark 45 76 26 00 45 76 26 02

Finland 09 725 725 11 09 725 725 55

France 0 1 48 14 24 24 0 1 48 14 24 14

Germany 089 741 31 30 089 714 60 35

Hong Kong 2645 3186 2686 8505

India 91805275406 91805275410

Israel 03 6120092 03 6120095

Italy 02 413091 02 4139215

Japan 03 5472 2970 03 5472 2977

Korea 02 596 7456 02 596 7455

Mexico (D.F.) 5 280 7625 5 520 3282

Mexico (Monterrey) 8 357 7695 8 365 8543

Netherlands 0348 433466 0348 430673

Norway 32 84 84 00 32 84 86 00

Singapore 2265886 2265887

Spain (Madrid) 91 640 0085 91 640 0533

Spain (Barcelona) 93 582 0251 93 582 4370

Sweden 08 587 895 00 08 730 43 70

Switzerland 056 200 51 51 056 200 51 55

Taiwan 02 2377 1200 02 2737 4644

United Kingdom 01635 523545 01635 523154

United States 512 795 8248 512 794 5678
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Prefix Meanings Value

n- nano- 10–9

µ- micro- 10– 6

m- milli- 10–3

k- kilo- 103

M- mega- 106

ANSI American National Standards Institute

applet program that can only be used within another application

ASCII American Standard Code for Information Interchange

B bytes

DIO digital input/output

DMA direct memory access

EOI end or identify

EOS End-of-String

FCC Federal Communications Commission

FIFO first-in-first-out

FTP file transfer protocol

GPIB General Purpose Interface Bus

hex hexadecimal

HS488 high-speed IEEE 488 transfers

Hz hertz

IEEE Institute of Electrical and Electronic Engineers
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I/O input/output

IRQ interrupt request

ISA Industry Standard Architecture

Kbytes kilobytes

LED light-emitting diode

legacy board ISA board whose system resources are chosen by changing physica
switches or jumpers on the board

m meters

MB megabytes of memory

PC personal computer

PCI Peripheral Component Interconnect

PCMCIA Personal Computer Memory Card International Association

PLC Programmable Logic Controller

RAM random-access memory

resource hardware settings used by devices in a computer system, including IS
interrupt level, DMA channel, and base I/O address

s seconds

VCCI Voluntary Control Council for Interference

VDC volts direct current

VXI VME eXtensions for Instrumentation
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